[
https://issues.apache.org/jira/browse/SLIDER-1187?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15828717#comment-15828717
]
Billie Rinaldi commented on SLIDER-1187:
----------------------------------------
Nice patch, [~gsaha]. I think this diagnostic information will be very helpful.
Comments below.
Since the other object in ClusterDescription is called
"ApplicationLivenessInformation," perhaps the new class should be named
"ApplicationDiagnostics." Not a big deal if you want to keep it as
AppDiagnostics, though.
Is the newline needed in SliderClient printDiagnosticContainers? I don't think
\n will work for Windows.
I think that storeContainerDiagnostics should be a method of AppState, and
AppState can handle setting the logLink internally rather than having the AM
pass it as a parameter. Most of the new methods in SliderAppMaster can be
handled in AppState.
In onContainerStopped, the AM has asked the container to stop, not the RM. I
don't think the container diagnostics should be updated for the NMClientAsync
callbacks onContainerStopped, onGetContainerStatusError, or
onStopContainerError. (The AM never calls nmClientAsync.stopContainer, so I
don't think it will ever see onContainerStopped or onStopContainerError. In any
case, it should receive container completion info from the RM. For
onGetContainerStatusError, I don't think that callback necessarily means
anything about the state of the container.) It makes sense to update
diagnostics for onStartContainerError and onContainerStatusReceived, as well as
the RM callback onContainersCompleted. I don't think the live log link needs to
updated in onContainerStatusReceived, because AppState is setting that when the
ContainerInformation is created.
Do you think this will cause memory issues for long-lived AMs?
> Create app diagnostics resource with placeholder for containers (live/dead)
> ---------------------------------------------------------------------------
>
> Key: SLIDER-1187
> URL: https://issues.apache.org/jira/browse/SLIDER-1187
> Project: Slider
> Issue Type: Sub-task
> Components: appmaster, client
> Affects Versions: Slider 0.91
> Reporter: Gour Saha
> Assignee: Gour Saha
> Fix For: Slider 1.0.0
>
> Attachments: SLIDER-1187.001.patch
>
>
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)