On 7 Sep 2004, at 05:13, [EMAIL PROTECTED] wrote:

------- Additional Comments From [EMAIL PROTECTED] 2004-09-06 21:13 -------
(Adding description that got lost in the original submission.)


This applies specifically to Mail/SpamAssassin/Plugin.pm but may also affect
other documentation.


In several places the PoD uses something similar to

    C<$permsgstatus->get_message()>

This is parsed as "C<$permsgstatus->" and "get_message()>" which is not what was
intended.


The doc should instead use

C<$permsgstatus-E<gt>get_message()>

Ewww, please no!

POD has a perfectly clean way to deal with this rather than using E<>:

  C<< $permsgstatus->get_message() >>

You need whitespace between the double-brackets and the text. I prefer this because it's MUCH more readable when scanning through text outside of a POD converter. If you need to have the bit-shift operator in the code you can use triple brackets.

Matt.


______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email ______________________________________________________________________

Reply via email to