On 06.03.2012 12:48, Julian Foad wrote:
stef...@apache.org wrote:

URL: http://svn.apache.org/viewvc?rev=1296640&view=rev
Log:
* subversion/libsvn_repos/rev_hunt.c
   (svn_repos_get_committed_info): use sizeof() instead of magic numbers
-  committed_date_s = apr_hash_get(revprops,
-                                  SVN_PROP_REVISION_DATE,
-                                  8);
[...]
+  committed_date_s = apr_hash_get(revprops,
+                                  SVN_PROP_REVISION_DATE,
+                                  sizeof(SVN_PROP_REVISION_DATE)-1);
[...]

Consider using the special value "APR_HASH_KEY_STRING".  Last time I looked at the APR 
hash source code, it looked like the implementation was (as far as I could see by inspection) 
approximately just as fast with "APR_HASH_KEY_STRING" as with passing the specific 
length.  Using it has the benefit of simplicity for the developers, reducing the opportunity for 
mistakes such as the one fixed by r1242353 (which is merely an example of an unnoticed typo in 
repetitive code, nothing to do with hash keys).

Hi Julian,

I'm aware of APR_HASH_KEY_STRING and APR's default-
hash function implementation.

A compatible, optimized variant of that sits in my commit queue
next to a ton of other things. In that code, the fixed-size variant
is about twice as fast as the variable-size one.

-- Stefan^2.

Reply via email to