Jens Geyer created THRIFT-5627:
----------------------------------

             Summary: More consistent syntax for cpp_type
                 Key: THRIFT-5627
                 URL: https://issues.apache.org/jira/browse/THRIFT-5627
             Project: Thrift
          Issue Type: Improvement
          Components: Compiler (General)
            Reporter: Jens Geyer
            Assignee: Jens Geyer


As a side effect on my current work I recognized a warning that was there 
before:

Essentially it boils down to the list in these definitions taken from 
https://thrift.apache.org/docs/idl

{code}
[28] MapType         ::=  'map' {color:#DE350B}CppType?{color} '<' FieldType 
',' FieldType '>'
[29] SetType         ::=  'set' {color:#DE350B}CppType?{color} '<' FieldType '>'
[30] ListType        ::=  'list' '<' FieldType '>' 
{color:#DE350B}CppType?{color}
{code}

I wonder why we need it this way at all. Wouldn't it be better if list<> set<> 
and map<> would expect the same syntax? 




--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to