[ 
https://issues.apache.org/jira/browse/TIKA-4925?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Gabor updated TIKA-4925:
------------------------
    Description: 
The Tika Helm Chart (v4.0.0) lacks support for the native Kubernetes 
`spec.ingressClassName` field inside `templates/ingress.yaml`. 
Additionally, the `values.schema.json` enforces `"additionalProperties": false` 
for the `ingress` configuration block. When attempting to pass 
`ingressClassName` from an umbrella/parent chart, the deployment fails with a 
schema validation error:
"Additional property ingressClassName is not allowed"
Since Kubernetes officially deprecated the old `kubernetes.io/ingress.class` 
annotation in version 1.22, the chart needs an update to support the modern 
native field without breaking the JSON schema validation.
Proposed Fix:
1. Allow `ingressClassName` (type: string) under properties.ingress in 
`values.schema.json`.

  was:
The Tika Helm Chart (v4.0.0) lacks support for the native Kubernetes 
`spec.ingressClassName` field inside `templates/ingress.yaml`. 
Additionally, the `values.schema.json` enforces `"additionalProperties": false` 
for the `ingress` configuration block. When attempting to pass 
`ingressClassName` from an umbrella/parent chart, the deployment fails with a 
schema validation error:
"Additional property ingressClassName is not allowed"
Since Kubernetes officially deprecated the old `kubernetes.io/ingress.class` 
annotation in version 1.22, the chart needs an update to support the modern 
native field without breaking the JSON schema validation.
Proposed Fix:
1. Allow `ingressClassName` (type: string) under properties.ingress in 
`values.schema.json`.
2. Add `ingressClassName: \{{ .Values.ingress.ingressClassName | quote }}` to 
`spec` in `templates/ingress.yaml`.


> Add native ingressClassName support to tika-helm chart and fix values schema 
> validation
> ---------------------------------------------------------------------------------------
>
>                 Key: TIKA-4925
>                 URL: https://issues.apache.org/jira/browse/TIKA-4925
>             Project: Tika
>          Issue Type: Bug
>          Components: tika-helm
>    Affects Versions: 4.0.0
>            Reporter: Gabor
>            Priority: Major
>
> The Tika Helm Chart (v4.0.0) lacks support for the native Kubernetes 
> `spec.ingressClassName` field inside `templates/ingress.yaml`. 
> Additionally, the `values.schema.json` enforces `"additionalProperties": 
> false` for the `ingress` configuration block. When attempting to pass 
> `ingressClassName` from an umbrella/parent chart, the deployment fails with a 
> schema validation error:
> "Additional property ingressClassName is not allowed"
> Since Kubernetes officially deprecated the old `kubernetes.io/ingress.class` 
> annotation in version 1.22, the chart needs an update to support the modern 
> native field without breaking the JSON schema validation.
> Proposed Fix:
> 1. Allow `ingressClassName` (type: string) under properties.ingress in 
> `values.schema.json`.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to