Stephen Mallette created TINKERPOP-3290:
-------------------------------------------

             Summary: TinkerGraph close() semantics should prevent further usage
                 Key: TINKERPOP-3290
                 URL: https://issues.apache.org/jira/browse/TINKERPOP-3290
             Project: TinkerPop
          Issue Type: Improvement
          Components: tinkergraph
    Affects Versions: 3.8.2
            Reporter: Stephen Mallette


{code}
gremlin> graph = TinkerGraph.open()
==>tinkergraph[vertices:0 edges:0]
gremlin> g = traversal().with(graph)
==>graphtraversalsource[tinkergraph[vertices:0 edges:0], standard]
gremlin> g.addV('person')
==>v[0]
gremlin> g.V().count()
==>1
gremlin> graph.close()
==>null
gremlin> g.addV('person')
==>v[1]
gremlin> g.V().count()
==>2
{code}

This will be at odds with the file-persistent version of TinkerGraph in 4.0 
where we will need {{close()} to actually prevent further usage. Need to align 
the pure in-memory graph with that.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to