[ 
https://issues.apache.org/jira/browse/TINKERPOP-3295?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Stephen Mallette updated TINKERPOP-3295:
----------------------------------------
    Description: 
{code}
  gremlin> g.inject(1,1).addV('X').id()
  ==>0
  ==>0
  gremlin> g.V().count()
  ==>1
{code}

the example is for {{addV()}} and the {{inject()}} start step but investigation 
should probably cover other variations of mutations like, {{addE()}}, 
{{mergeV/E()}} and {{drop()}} and steps and mid-traversal {{inject()}}.

Should also cover cases like: {{g.inject(1, 1).addV('X').property(T.id, 
'same')}}

  was:
{code}
  gremlin> g.inject(1,1).addV('X').id()
  ==>0
  ==>0
  gremlin> g.V().count()
  ==>1
{code}

the example is for {{addV()}} and the {{inject()}} start step but investigation 
should probably cover other variations of mutations like, {{addE()}}, 
{{mergeV/E()}} and {{drop()}} and steps and mid-traversal {{inject()}}.


> inject() and addV() has bulking issues
> --------------------------------------
>
>                 Key: TINKERPOP-3295
>                 URL: https://issues.apache.org/jira/browse/TINKERPOP-3295
>             Project: TinkerPop
>          Issue Type: Bug
>          Components: process
>    Affects Versions: 3.7.7
>            Reporter: Stephen Mallette
>            Priority: Critical
>
> {code}
>   gremlin> g.inject(1,1).addV('X').id()
>   ==>0
>   ==>0
>   gremlin> g.V().count()
>   ==>1
> {code}
> the example is for {{addV()}} and the {{inject()}} start step but 
> investigation should probably cover other variations of mutations like, 
> {{addE()}}, {{mergeV/E()}} and {{drop()}} and steps and mid-traversal 
> {{inject()}}.
> Should also cover cases like: {{g.inject(1, 1).addV('X').property(T.id, 
> 'same')}}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to