[ 
https://issues.apache.org/jira/browse/TINKERPOP-3295?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18126793#comment-18126793
 ] 

Cole Greer commented on TINKERPOP-3295:
---------------------------------------

Note that this appears to apply in general to a mid-traversal addV operating on 
bulked traversers, I do not believe it is anything special about inject() or 
any other potential start-step.


{code:java}
gremlin> g.V().constant(25).barrier().addV()
==>v[0]
==>v[0]
==>v[0]
==>v[0]
==>v[0]
==>v[0]
gremlin> g.V(0).count()
==>1

// without bulking:
gremlin> g.V().constant(25).addV()
==>v[13]
==>v[14]
==>v[15]
==>v[16]
==>v[17]
==>v[18]
==>v[19]
{code}


> inject() and addV() has bulking issues
> --------------------------------------
>
>                 Key: TINKERPOP-3295
>                 URL: https://issues.apache.org/jira/browse/TINKERPOP-3295
>             Project: TinkerPop
>          Issue Type: Bug
>          Components: process
>    Affects Versions: 3.7.7
>            Reporter: Stephen Mallette
>            Priority: Critical
>
> {code}
>   gremlin> g.inject(1,1).addV('X').id()
>   ==>0
>   ==>0
>   gremlin> g.V().count()
>   ==>1
> {code}
> the example is for {{addV()}} and the {{inject()}} start step but 
> investigation should probably cover other variations of mutations like, 
> {{addE()}}, {{mergeV/E()}} and {{drop()}} and steps and mid-traversal 
> {{inject()}}.
> Should also cover cases like: {{g.inject(1, 1).addV('X').property(T.id, 
> 'same')}}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to