[EMAIL PROTECTED] wrote:
Author: rjung
Date: Sun Sep  2 15:50:40 2007
New Revision: 572181

URL: http://svn.apache.org/viewvc?rev=572181&view=rev
Log:
- Document return codes of the service() method for
  all worker types (lb still missing).
Below is for jk_ajp_common.c:
- Document return codes of ajp_send_request() and
  ajp_get_reply().
- Fix log message typo
- Don't use the recovery_options for idempotent GET
  and HEAD in case we already sent the headers.
- We don't need to handle JK_FATAL_ERROR for
  ajp_process_callback() in ajp_get_reply().
- Handle JK_INTERNAL_ERROR instead of JK_SERVER_ERROR
  for ajp_process_callback() in ajp_get_reply().
- Add some logging for unexpected default case in
  return code handling.
- Move complete handling of return codes of
  ajp_send_request() in front of return code handling
  for ajp_get_reply() in service().
- Some XXXs still open: return codes, is_error
  and op->recoverable for unexpected cases.
We still need a better design for returning enough
information from service() of a member to an lb,
such that the lb can decide about recovery and if the
member should be put in error state.

Modified:
    tomcat/connectors/trunk/jk/native/common/jk_ajp12_worker.c
    tomcat/connectors/trunk/jk/native/common/jk_ajp_common.c
    tomcat/connectors/trunk/jk/native/common/jk_jni_worker.c
    tomcat/connectors/trunk/jk/native/common/jk_status.c



Huh, this is one huge single commit :(
I must say it's really hard to follow something like that, and now I
see that I'll for sure never do again something like that by myself.

Can we in the future try to make the commits that a single-topic
related? I know it's additional hassle, but lot less then the one
when someone really tries to understand the patch.


Regards,
Mladen.

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to