This is an automated email from the ASF dual-hosted git repository.

rmaucher pushed a change to branch 9.0.x
in repository https://gitbox.apache.org/repos/asf/tomcat.git


    from 1e8b11fd73 Partial revert of 99d1d567
     new d737613bc1 Delegate awaitTermination() in StandardThreadExecutor and 
StandardVirtualThreadExecutor to the wrapped executor rather than 
unconditionally returning false which violates the ExecutorService contract
     new c912cdd937 Synchronise the check and assignment of the servlet 
instance in getServletMethods() to prevent a race which could result in a 
second, never initialised instance being retained by the wrapper
     new 90b8a939ae Validate the incoming entry at the start of 
NamingResourcesImpl.addEnvironment() so that an entry which is ignored or 
rejected cannot first destroy the existing environment entry or resource link 
with the same name
     new bde0fbc97c Retain an existing resource link in 
NamingResourcesImpl.addEnvironment() when the link's global target is not an 
overridable global environment rather than adding an environment entry with the 
same name which would create a duplicate JNDI binding
     new cb79399ce5 Merge branch '10.1.x' of [email protected]:apache/tomcat.git 
into 10.1.x
     new 2b5431b2a4 Only release the shared naming entry name in 
NamingResourcesImpl remove*() methods when the type-specific map actually held 
the entry, preventing the removal of the JNDI name reservation of a differently 
typed descriptor with the same name
     new 03f297d2bd Use the atomic add() of the shared entries set as the name 
claim in all NamingResourcesImpl add*() methods to close the check-then-act 
race which could allow two descriptors with the same JNDI name to both be 
registered
     new 6080ad30f1 Fix return statement

The 8 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 .../catalina/core/StandardThreadExecutor.java      |   6 +-
 .../core/StandardVirtualThreadExecutor.java        |   6 +-
 java/org/apache/catalina/core/StandardWrapper.java |   9 +-
 .../catalina/deploy/NamingResourcesImpl.java       | 203 ++++++++++++---------
 .../core/TestExecutorAwaitTermination.java         |  75 ++++++++
 5 files changed, 214 insertions(+), 85 deletions(-)
 create mode 100644 
test/org/apache/catalina/core/TestExecutorAwaitTermination.java


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to