[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-1817?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13824970#comment-13824970
 ] 

Raul Gutierrez Segales commented on ZOOKEEPER-1817:
---------------------------------------------------

One more nit (sorry [~fpj]) in:

{noformat}
-        return "(" + id + ", " + Long.toHexString(zxid) + ", " + 
Long.toHexString(peerEpoch) + ")";
+        return "(" + id + ", " 
+                               + Long.toHexString(zxid) 
+                               + ", " + Long.toHexString(peerEpoch) 
+                               + ")";
{noformat}

should we encourage String.format instead of concatenation (as we do in LOG 
statements with {})? I think this is more readable:

{noformat}
-        return "(" + id + ", " + Long.toHexString(zxid) + ", " + 
Long.toHexString(peerEpoch) + ")";
+        return String.format("(%d, %s, %s)", id, Long.toHexString(zxid), 
Long.toHexString(peerEpoch));
{noformat}

What do you think?


> Fix don't care for b3.4
> -----------------------
>
>                 Key: ZOOKEEPER-1817
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1817
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Flavio Junqueira
>            Assignee: Flavio Junqueira
>            Priority: Blocker
>             Fix For: 3.4.6
>
>         Attachments: ZOOKEEPER-1817.patch, ZOOKEEPER-1817.patch, 
> ZOOKEEPER-1817.patch
>
>
> See umbrella jira.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Reply via email to