[ 
https://issues.apache.org/jira/browse/ZOOKEEPER-2517?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15473148#comment-15473148
 ] 

Arshad Mohammad commented on ZOOKEEPER-2517:
--------------------------------------------

Thanks [~eribeiro], Handled review comments, please have a look
# instead of just checking trimmed value length, we should use the trimmed 
value. Not checking length after trim to log the warning
# getInt is a common class. The classes using it will log the returned value. 
If it was a method meant to be used in specific class, no doubt it would have 
been a WARN. no problem, changing to WARN
# Because getInt is a small method and I was testing the complete getInt method 
but it can be renamed to testIntegerRetrievalFromProperty]Handled review 
comments, please have a look.

> jute.maxbuffer is ignored
> -------------------------
>
>                 Key: ZOOKEEPER-2517
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-2517
>             Project: ZooKeeper
>          Issue Type: Bug
>    Affects Versions: 3.5.2
>            Reporter: Benjamin Jaton
>            Assignee: Arshad Mohammad
>            Priority: Blocker
>             Fix For: 3.5.3, 3.6.0
>
>         Attachments: ZOOKEEPER-2517-01.patch, ZOOKEEPER-2517.patch
>
>
> In ClientCnxnSocket.java the parsing of the system property is erroneous:
> {code}packetLen = Integer.getInteger(
>   clientConfig.getProperty(ZKConfig.JUTE_MAXBUFFER),
>   ZKClientConfig.CLIENT_MAX_PACKET_LENGTH_DEFAULT
> );{code}
> Javadoc of Integer.getInteger states "The first argument is treated as the 
> name of a system property", whereas here the value of the property is passed.
> Instead I believe the author meant to write something like:
> {code}packetLen = Integer.parseInt(
>   clientConfig.getProperty(
>     ZKConfig.JUTE_MAXBUFFER,
>     String.valueOf(ZKClientConfig.CLIENT_MAX_PACKET_LENGTH_DEFAULT)
>   )
> );{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to