Severity: important 
    CVSS 4.0: 8.7 (high) 
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Affected versions:

- Apache ZooKeeper 3.9.0 through 3.9.6
- Apache ZooKeeper 3.8.0 through 3.8.7

Description:

Improper handling of exceptional conditions in the quota subsystem of Apache 
ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — 
unauthenticated on default deployments, where that subtree is world-writable — 
to crash the server's critical request-processing thread and render the on-disk 
data directory permanently unbootable.

This issue affects Apache ZooKeeper up to and including 3.9.6. Users are 
recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.

Credit:

cunyi li <[email protected]> (reporter)

References:

https://zookeeper.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-100300

Reply via email to