> 
> +    UINT32    HW_FEEDBACK                            : 1;
Though the field name looks strange and inconsistent with other field naming 
styles, it does
follow the SDM content. Looks good to me.

> 
> -    UINT32    Reserved2                    : 28;
> 
> +    UINT32    Reserved2                    : 4;

1. The bit width is changed. We should use an used name "Reserved3" not the 
original field name.

> 
> +    ///
> 
> +    /// {Bit 15:8] Number of Intel Thread Director classes supported by the
> processor. Information for that
> 
> +    /// many classes is written into the Intel Thread Director Table by the
> hardware.
> 
> +    ///
> 
> +    UINT32    ThreadDirectorClasses        : 8;

2. To better match the SDM, how about "NumberOfThreadDirectorClasses"?


> 
> +    UINT32    Reserved3                    : 16;
4. "Reserved4"

> 
> 
> +    ///
> 
> +    /// {Bits 11:8] Enumerates the size of the hardware feedback interface
> structure in number of 4 KB pages;
> 
> +    /// add one to the return value to get the result.
> 
> +    ///
> 
> +    UINT32    InterfaceStructureSize   : 4;

5. "InterfaceStructureSizeIn4K"



-=-=-=-=-=-=-=-=-=-=-=-
Groups.io Links: You receive all messages sent to this group.
View/Reply Online (#100283): https://edk2.groups.io/g/devel/message/100283
Mute This Topic: https://groups.io/mt/96324028/21656
Group Owner: devel+ow...@edk2.groups.io
Unsubscribe: 
https://edk2.groups.io/g/devel/leave/9847357/21656/1706620634/xyzzy 
[arch...@mail-archive.com]
-=-=-=-=-=-=-=-=-=-=-=-


Reply via email to