On 04/10/2019 16:05, Joel Sherrill wrote:


On Fri, Oct 4, 2019 at 12:02 AM Sebastian Huber <sebastian.hu...@embedded-brains.de <mailto:sebastian.hu...@embedded-brains.de>> wrote:

    On 04/10/2019 00:08, Joel Sherrill wrote:
     > This adds back the capability for the BSP to configure an
     > initial extension that is specific to itself. The parameter
     > BSP_INITIAL_EXTENSION was taken over by having a standard
     > fatal extension installed using the same name.
     > ---
     >   cpukit/include/rtems/confdefs.h | 3 +++
     >   1 file changed, 3 insertions(+)
     >
     > diff --git a/cpukit/include/rtems/confdefs.h
    b/cpukit/include/rtems/confdefs.h
     > index 5eb5425..e1a255a 100644
     > --- a/cpukit/include/rtems/confdefs.h
     > +++ b/cpukit/include/rtems/confdefs.h
     > @@ -2136,6 +2136,9 @@ extern rtems_initialization_tasks_table
    Initialization_tasks[];
     >       #if defined(CONFIGURE_INITIAL_EXTENSIONS)
     >         CONFIGURE_INITIAL_EXTENSIONS,
     >       #endif
     > +    #if defined(BSP_INITIAL2_EXTENSIONS)
     > +      BSP_INITIAL2_EXTENSIONS,
     > +    #endif
     >       #if defined(BSP_INITIAL_EXTENSION)
     >         BSP_INITIAL_EXTENSION
     >       #endif
     >

    I don't think this patch is necessary. A BSP is free to provide its own
    initial extension. Just don't add the

    #include <bsp/default-initial-extension.h>

    to the bsp.h.


And why would I want to lose the default fatal extension? The point of BSP_INITIAL_EXTENSION was for a BSP to add it's own extensions. I like the default extensions but the BSP should still have a
hook.

I would prefer to rename this to BSP_FATAL_EXTENSION and leave the BSP_INITIAL_EXTENSION
available.

I think I could fix this by for this BSP by something like this:

#include <bsp/default-initial-extension.h>

#undef BSP_INITIAL_EXTENSION
#define BSP_INITIAL_EXTENSION
    {
      ... switch extension ...,
     ... default fatal extension
   }

Is that what you are proposing a user should do if they want to another extension but still
use the default fatal extension?

FWIW other BSPs uses this default extension and just provide their own bsp_fatal_extension()
implementation. That seems OK and slightly different from my use case.

I think a BSP should just provide one extension via BSP_INITIAL_EXTENSION defined by <bsp.h>. The declaration of bsp_fatal_extension() should move to a separate header file. It can then be used in a custom BSP extension.

--
Sebastian Huber, embedded brains GmbH

Address : Dornierstr. 4, D-82178 Puchheim, Germany
Phone   : +49 89 189 47 41-16
Fax     : +49 89 189 47 41-09
E-Mail  : sebastian.hu...@embedded-brains.de
PGP     : Public key available on request.

Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
_______________________________________________
devel mailing list
devel@rtems.org
http://lists.rtems.org/mailman/listinfo/devel

Reply via email to