From: Srinivas Kandagatla <srinivas.kandaga...@st.com>

This patch series introduces of_get_child_by_name function to get a 
child node by its name in a given parent node and also removes code 
duplication in some of the existing driver code by using of_get_child_by_name.

Normally if a driver want to get a child node it would iterate all the nodes
of parent and compare its name and then get it.
This use case is becoming common as device trees are used more, so moving this 
functionality to a libary function makes sense.

Having of_get_child_by_name libary function would avoid code duplication,
errors and is more convenient.

Changes from v1:
        -rename of_get_child to of_get_child_by_name.
        -remove read lock in of_get_child_by_name.
        -make use of of_get_child_by_name in the existing kernel code.

Srinivas Kandagatla (7):
  dt: introduce of_get_child_by_name to get child node by name.
  dt/powerpc: Use of_get_child_by_name to get a named child.
  dt/powerpc/powernv: Use of_get_child_by_name to get a named child.
  dt/powerpc/sysdev: Use of_get_child_by_name to get a named child.
  dt/net/fsl_pq_mdio: Use of_get_child_by_name to get a named child.
  dt/s3c64xx/spi: Use of_get_child_by_name to get a named child.
  dt/tty/opal: Use of_get_child_by_name to get a named child.

 arch/powerpc/kernel/prom.c                   |    5 +----
 arch/powerpc/platforms/powernv/opal.c        |    6 ++----
 arch/powerpc/sysdev/qe_lib/qe.c              |    5 +----
 drivers/net/ethernet/freescale/fsl_pq_mdio.c |    5 +----
 drivers/of/base.c                            |   25 +++++++++++++++++++++++++
 drivers/spi/spi-s3c64xx.c                    |    4 +---
 drivers/tty/hvc/hvc_opal.c                   |    9 ++-------
 include/linux/of.h                           |    2 ++
 8 files changed, 35 insertions(+), 26 deletions(-)

_______________________________________________
devicetree-discuss mailing list
devicetree-discuss@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/devicetree-discuss

Reply via email to