From: Srinivas Kandagatla <srinivas.kandaga...@st.com>

As follow-up to "dt: introduce of_get_child_by_name to get child node by
name." patch, This patch removes some of the code duplication in the
driver by replacing it with of_get_child_by_name instead.

Signed-off-by: Srinivas Kandagatla <srinivas.kandaga...@st.com>
---
 arch/powerpc/sysdev/qe_lib/qe.c |    5 +----
 1 files changed, 1 insertions(+), 4 deletions(-)

diff --git a/arch/powerpc/sysdev/qe_lib/qe.c b/arch/powerpc/sysdev/qe_lib/qe.c
index b043675..fd1c15d 100644
--- a/arch/powerpc/sysdev/qe_lib/qe.c
+++ b/arch/powerpc/sysdev/qe_lib/qe.c
@@ -568,10 +568,7 @@ struct qe_firmware_info *qe_get_firmware_info(void)
        }
 
        /* Find the 'firmware' child node */
-       for_each_child_of_node(qe, fw) {
-               if (strcmp(fw->name, "firmware") == 0)
-                       break;
-       }
+       fw = of_get_child_by_name(qe "firmware");
 
        of_node_put(qe);
 
-- 
1.7.0.4

_______________________________________________
devicetree-discuss mailing list
devicetree-discuss@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/devicetree-discuss

Reply via email to