Andrei Alexandrescu pisze:
John Reimer wrote:
Hello Christopher,

Walter Bright wrote:

Yigal Chripun wrote:

Walter Bright wrote:

Lars Ivar Igesund wrote:

toe() ?! tail() good, rear() not so good, toe() sucks.

tail() is no good because it has a well-established meaning in
programming of being everything but the first element of a list. I
just didn't like rear(), as it is not normally thought of as the
opposite of head().

What was the reason for the use of body parts in the first place?
What's wrong with:
a) begin, end
b) start, finish
c) initial, final
d) first, last
etc...
There doesn't really need to be anything wrong with them. What's
wrong with head/toe?

It sounds stupid.



I agree that its ugly. Although, be prepared to see it turn into just another feature that we're going to have to get used to. :)

If there's widespread opinion that the current choice of names is unfortunate, now is the perfect time to fix that as the names haven't been put in heavy use.

Things to keep in mind:

* The operations next and retreat are not necessarily antonyms. I mean retreat does NOT undo what next does. So next and previous aren't quite desirable.

* "head" will be used much more often than "toe". Most of the time, empty, head, and next will be used. These are the elements that support input ranges. "toe" and "retreat" are for bidirectional ranges.

* The terms should be applicable equally well to generators (series, random numbers...), streams (files, sockets...), collections (lists, arrays...) and the such.

* Short, one-word terms are preferred.

Last but not least, keep in mind that these discussions could go on forever and that someone's best naming convention is another's worst. Happy hunting :o).


Andrei

first - last
advance - retreat

Above seems to me much more streamlined, than current choice.

BR
Marcin Kuszczak
(aarti_pl)

Reply via email to