07-Mar-2014 21:34, H. S. Teoh пишет:
On Fri, Mar 07, 2014 at 05:24:59PM +0000, Vladimir Panteleev wrote:
On Friday, 7 March 2014 at 03:52:42 UTC, Walter Bright wrote:
Ok, I have a plan. Each step will be separated by at least one
version:

1. implement decode() as an algorithm for string types, so one can
write:

    string s;
    s.decode.algorithm...

suggest that people start doing that instead of:

    s.algorithm...

I think .decode should be something more explicit (byCodePoint
OSLT), just so it's clear that it's not magical and does not solve
all problems.

+1. I think "byCodePoint" is far more self-documenting and less
misleading than "decode".

        string s;
        s.byCodePoint.algorithm...

I'm already starting to like it.

And there is precedent, see std.uni.byCodepoint ;)


--
Dmitry Olshansky

Reply via email to