I've been using recursion a lot lately and having to create multiple functions to deal with multiple paths can be a pain visually.

Instead, how bout a simpler syntax. This is just an idea, could be improved

void Recurse()
{
    scope(first)
    {
         `BLOCK`
    }
    scope(last)
    {
         `BLOCK`
    }

    Recurse();
}

which would be equivalent to

void Recurse2()
{
    Recurse2();
}

void Recurse()
{
    `BLOCK`
    Recurse2();
    `BLOCK`
}

doubling of functions starts to create a source mess.

Reply via email to