On 04/26/2018 01:13 PM, arturg wrote:

why do people use this syntax?

if val == someVal

or

while val != someVal

it makes editing the code harder then if you use if(val == someVal).

The theory goes:

A. "less syntax => easier to read".
B. "There's no technical need to require it, and everything that can be removed should be removed, thus it should be removed".

Personally, I find the lack of parens gives my brain's visual parser insufficient visual cues to work with, so I always find it harder to read. And regarding "B", I just don't believe in "less is more" - at least not as an immutable, universal truth anyway. Sometimes it's true, sometimes it's not.

Reply via email to