Don wrote:
> 
> But 'goto case XXX' is an extremely rarely encountered construct, that
> screams 'Examine this code closely'. So I don't think it needs extra
> error checking.

Oh, I don't think that it's a big issue. We have "goto case XXX" and "goto 
case," so we could use them to enforce flow control statements at the end of 
case blocks without changing anything other than what the compiler complains 
about. I definitely think that "continue switch" is less error prone than 
"goto case," and I'd prefer "continue switch," but "goto case XXX" is indeed 
rare enough that the frequency of screwing up and using "goto case" instead 
of "goto case XXX" would be quite small. So, I definitely find "continue 
switch" to be preferable, but it's not a big deal.

- Jonathan M Davis

Reply via email to