On 12/02/11 9:16 PM, Nick Sabalausky wrote:
"Andrei Alexandrescu"<[email protected]> wrote in messageNot all users dislike iota, and besides arguments ad populum are fallacious. Iota rocks. But have at it - vote away, and I'll be glad if a better name for iota comes about.I vote "a..b:c" and "step"
As Michel pointed out, a..b:c is ambiguous. auto foo = [ 1..10 : 2, 2..20 : 3 ]; Is foo an AA of ranges to ints, or an array of stepped ranges?
