On Mon, 12 Sep 2011 01:51:02 +0900, dsimcha <dsim...@yahoo.com> wrote:

8. The high-level, templated allocator functions now have a default implementation in terms of lower-level allocator functionality, provided by the TypedAllocatorMixin mixin in std.allocators.allocator. The idea is that an allocator may have better ways of accomplishing this stuff, but this mixin is usually a reasonable default and will avoid code duplication across allocators. I'm leery of including it in the DynamicAllocator interface, though, because for some allocators it's just plain wrong. For example, the default array() implementation just plain wouldn't work with RegionAllocator for huge ranges.

I think Default(Templated)AllocatorFunctions are better
than TypedAllocatorMixin. TypedAllocator is not clear for me.

I will read documents and codes later.

Reply via email to