On 2012-09-24 17:24, Andrei Alexandrescu wrote:

I think my main problem with this is that I'm perfectly happy with the
baseline, which has "tuple(" as the left delimiter and ")" as the right
delimiter. I'd be more excited to invent notation if there was
overwhelming or at least considerable evidence that the notation
considerably helps certain use cases, or is very frequent. As things
are, I'd be quite "meh" about suddenly adding lenses.

Declaring a tuple is still quire verbose can could really benefit from a shorter syntax.

(int, int) foo ();

Vs

import std.typecons;

Tuple!(int, int) foo (); // or what the correct syntax is

--
/Jacob Carlborg

Reply via email to