#16845: Admin should hide password hash field by default
--------------------------------------+------------------------------------
     Reporter:  PaulM                 |                    Owner:  PaulM
         Type:  Cleanup/optimization  |                   Status:  closed
    Component:  contrib.auth          |                  Version:  1.3
     Severity:  Release blocker       |               Resolution:  fixed
     Keywords:                        |             Triage Stage:  Accepted
    Has patch:  1                     |      Needs documentation:  0
  Needs tests:  0                     |  Patch needs improvement:  0
Easy pickings:  0                     |                    UI/UX:  0
--------------------------------------+------------------------------------

Comment (by adrian):

 Thanks for the patch, dstufft. I made these changes before committing:

 * Made a {{{mask_password}}} function so as not to duplicate the logic.
 * Renamed {{{ReadOnlyHashedPassword*}}} to {{{ReadOnlyPasswordHash*}}}
 because I thought it was more readable/direct.
 * Removed the help_text from the User.password field now that we're not
 using that.
 * Moved the "if not value" check to be the first statement within
 {{{ReadOnlyPasswordHashWidget.render()}}} so as to fail faster, in that
 case.
 * Rewrote the {{{help_text}}} for {{{UserChangeForm.password}}} so that
 it's friendlier for people who are not sysadmin types.

-- 
Ticket URL: <https://code.djangoproject.com/ticket/16845#comment:12>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To post to this group, send email to django-updates@googlegroups.com.
To unsubscribe from this group, send email to 
django-updates+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/django-updates?hl=en.

Reply via email to