On 8/11/23 03:52, Nitesh Shetty wrote:
+               if (rem != chunk)
+                       atomic_inc(&cio->refcount);

This code will be easier to read if the above if-test is left out
and if the following code is added below the for-loop:

        if (atomic_dec_and_test(&cio->refcount))
                blkdev_copy_endio(cio);

Thanks,

Bart.

--
dm-devel mailing list
dm-devel@redhat.com
https://listman.redhat.com/mailman/listinfo/dm-devel

Reply via email to