Johan Hake wrote:
> On Wednesday 08 July 2009 13:11:41 Garth N. Wells wrote:
>> Johan Hake wrote:
>>> On Wednesday 08 July 2009 12:53:18 DOLFIN wrote:
>>>> One or more new changesets pushed to the primary dolfin repository.
>>>> A short summary of the last three changesets is included below.
>>>>
>>>> changeset:   6449:c1849c5f9e724cb4c44f8ed5524fd197fdc50c82
>>>> tag:         tip
>>>> parent:      6447:ddb4cb628653d60fb0899b17a987bdc3e67d21ee
>>>> parent:      6448:8d67617c807120e17d580cad78ab6658891c13b4
>>>> user:        "Garth N. Wells <gn...@cam.ac.uk>"
>>>> date:        Wed Jul 08 11:53:12 2009 +0100
>>>> files:
>>>> description:
>>>> merge.
>>>>
>>>>
>>>> changeset:   6448:8d67617c807120e17d580cad78ab6658891c13b4
>>>> parent:      6446:7de811329be29b60aeb9b0f8ca2d5c6a07245668
>>>> user:        "Garth N. Wells <gn...@cam.ac.uk>"
>>>> date:        Wed Jul 08 11:52:18 2009 +0100
>>>> files:       dolfin/la/PETScKrylovSolver.cpp
>>>> dolfin/la/uBLASKrylovSolver.cpp dolfin/parameter/Parameters.cpp
>>>> dolfin/parameter/Parameters.h description:
>>>> Add Parameters::set_key(std::string) to change name of a parameter set.
>>>>
>>>> e.g.
>>>>
>>>>   Parameters uBLASKrylovSolver::default_parameters()
>>>>   {
>>>>     Parameters p(KrylovSolver::default_parameters());
>>>>     p.set_key("ublas_krylov_solver");
>>>>     return p;
>>>>   }
>>> Would set_name be a better name? set_key makes me think of the key to a
>>> parameter, instead of the name of the parameter set.
>> I used 'set_key' in the end since 'key' is  used elsewhere. The thing is
>> that in the context of nested parameters sets, the name is a key (key
>> for a set).
> 
> See your point. But when you change the key it really is a name of the 
> parameters set you change. It is not a key until you put it into another 
> parameters set.
>

I'm not fixed on a name, but for consistency we should have either

   std::string key() const;
   void set_key(std::string);

(which we have now) or

   std::string name() const;
   void set_name(std::string);

Garth

> Johan
> 
>> Garth
>>
>>> Johan
>>>
>>>> changeset:   6447:ddb4cb628653d60fb0899b17a987bdc3e67d21ee
>>>> user:        "Johan Hake <h...@simula.no>"
>>>> date:        Wed Jul 08 11:44:07 2009 +0200
>>>> files:       SConstruct
>>>> description:
>>>> Changed PathVariable.PathIsDirCreate to PathVariable.PathAccept
>>>>
>>>> ----------------------------------------------------------------------
>>>> For more details, visit http://www.fenics.org/hg/dolfin
>>>> _______________________________________________
>>>> DOLFIN-dev mailing list
>>>> DOLFIN-dev@fenics.org
>>>> http://www.fenics.org/mailman/listinfo/dolfin-dev
>>> _______________________________________________
>>> DOLFIN-dev mailing list
>>> DOLFIN-dev@fenics.org
>>> http://www.fenics.org/mailman/listinfo/dolfin-dev
> 
> 
_______________________________________________
DOLFIN-dev mailing list
DOLFIN-dev@fenics.org
http://www.fenics.org/mailman/listinfo/dolfin-dev

Reply via email to