On Sun, 2005-06-26 at 21:25 -0400, Jon Smirl wrote: > On 6/26/05, Eric Anholt <[EMAIL PROTECTED]> wrote: > > Are you saying this: > > if ((offset>=dev_priv->fb_location) && > > (offset<dev_priv->gart_vm_start)) return 0; > > is more readable than: > > if ((offset >= dev_priv->fb_location) && > > (offset < dev_priv->gart_vm_start)) > > return 0; > > Lindent would do this even with the wrap set at 80 columns. > if ((offset>=dev_priv->fb_location) && (offset<dev_priv->gart_vm_start)) > return 0; > > This is from the DRM code formatted with an 80 column limit. Lindent > will let strings exceed 80 columns. To me it look like 13 lines of > code turned into 28.
Heh. One of the suggestions of BSD style is that when 80 columns becomes too little, you probably need another function. In the diff I'm currently testing for cleaning up map handling (which net removes 200 lines), I've removed that if statement that didn't need to exist (afaict), and split the find-the-map bits into another function. I think it's quite improved. -- Eric Anholt [EMAIL PROTECTED] http://people.freebsd.org/~anholt/ [EMAIL PROTECTED] ------------------------------------------------------- SF.Net email is sponsored by: Discover Easy Linux Migration Strategies from IBM. Find simple to follow Roadmaps, straightforward articles, informative Webcasts and more! Get everything you need to get up to speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click -- _______________________________________________ Dri-devel mailing list Dri-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/dri-devel