Dne 27.8.2010 00:50, Eric Anholt napsal(a):
>  include/drm/drm.h    |    4 ++++
>  intel/intel_bufmgr.h |    6 +++++-
>  2 files changed, 9 insertions(+), 1 deletion(-)
> 
> New commits:
> commit 23287f05cf2443ddf9e028e29beb5bd30979c6cf
> Author: Eric Anholt <e...@anholt.net>
> Date:   Thu Aug 26 15:39:28 2010 -0700
> 
>     Avoid use of c++ reserved keyword "virtual" when using a C++ compiler.
>     
>     Avoids requiring nasty hacks around libdrm headers in the new C++
>     parts of Mesa drivers.
> 
> diff --git a/include/drm/drm.h b/include/drm/drm.h
> index a0559eb..2ba7136 100644
> --- a/include/drm/drm.h
> +++ b/include/drm/drm.h
> @@ -373,7 +373,11 @@ struct drm_buf_pub {
>   */
>  struct drm_buf_map {
>       int count;              /**< Length of the buffer list */
> +#ifdef __cplusplus
> +     void *virt;
> +#else
>       void *virtual;          /**< Mmap'd area in user-virtual */
> +#endif
>       struct drm_buf_pub *list;       /**< Buffer information */
>  };


Quit weird patch....

Why keeping different name for C++ and C ?

Why not simply use i.e.:

     void*  user_virtual;

Or something similar - and avoid using these rather useless ifdefs ?

Zdenek

------------------------------------------------------------------------------
Sell apps to millions through the Intel(R) Atom(Tm) Developer Program
Be part of this innovative community and reach millions of netbook users 
worldwide. Take advantage of special opportunities to increase revenue and 
speed time-to-market. Join now, and jumpstart your future.
http://p.sf.net/sfu/intel-atom-d2d
--
_______________________________________________
Dri-devel mailing list
Dri-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/dri-devel

Reply via email to