On Wed, 2015-01-14 at 09:32 +0100, Arnd Bergmann wrote: > On Wednesday 14 January 2015 09:20:42 Patrick Boettcher wrote: > > diff --git a/drivers/staging/android/sync_debug.c > > b/drivers/staging/android/sync_debug.c [] > > @@ -96,7 +96,8 @@ static void sync_print_pt(struct seq_file *s, struct > > sync_pt *pt, bool fence) > > sync_status_str(status)); > > > > if (status <= 0) { > > - struct timespec64 ts64 = > > ktime_to_timespec64(pt->base.timestamp); > > + struct timespec64 ts64 = > > + ktime_to_timespec64(pt->base.timestamp); > > > > seq_printf(s, "@%lld.%09ld", (s64)ts64.tv_sec, > > ts64.tv_nsec); > > } > > > > You are not really improving readability by just wrapping the line > arbitrarily though. > > If you're offended by the long line, better rework the code so the long > line is not needed.
Generally the best way to do that is to separate the declaration from the initialization like: if (status <= 0) { struct timespec64 ts64; ts64 = ktime_to_timespec64(pt->base.timestamp); seq_printf(s, "@%lld.%09ld", (s64)ts64.tv_sec, ts64.tv_nsec); } _______________________________________________ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel