On Mon, Jul 27, 2015 at 04:10:29PM +0800, Navy Cheng wrote:
>       if (rc < 0)
> -             return rc;
> +             goto end;

Ideally, you should be able to guess from the label name sort of what
the goto does.  Good names are like "goto unregister;" or
"goto err_free_sd;".  "end" is a bad name because it doesn't tell you
what the goto does.

Gotos which do nothing are a waste of time.

regards,
dan carpenter

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to