On 03/23/18 17:23, Andy Shevchenko wrote:
> On Thu, Mar 22, 2018 at 11:37 PM, Kirill Marinushkin
> <k.marinush...@gmail.com> wrote:
>
>
>> +static void snd_devm_release(struct device *dev)
>> +{
>> +       struct bcm2835_chip *chip = dev_get_drvdata(dev);
>> +
>> +       kfree(chip);
>> +}
>> +       device->release = snd_devm_release;
> This is not devm function, so, it would be rather called
> snd_bcm2835_release().

Ah, you mean "devm" in the names. Now I got it.
Agree, I will rename it to "snd_bcm2835_release()"

>
>>  static struct snd_card *snd_devm_card_new(struct device *dev)
>>  {
>>         struct snd_card *card;
>>         int ret;
>>
>>         ret = snd_card_new(dev, -1, NULL, THIS_MODULE, 0, &card);
>> +       if (ret)
>>                 return ERR_PTR(ret);
>>
>>         return card;
>>  }
> Same here. You removed anything related to devm here, so, please make
> function name consistent.

Good, I will rename it to "snd_bcm2835_card_new()"

> After addressing above, FWIW,
>
> Reviewed-by: Andy Shevchenko <andy.shevche...@gmail.com>
>

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to