On Fri, Mar 23, 2018 at 05:26:01PM +0100, Sergio Paracuellos wrote:
> This commits replaces custom defines that were been used
> to define a mask using GENMASK macro from linux bitops
> header file.
> 
> With this change the "WARNING: line over 80 characters"
> warning message reported by checkpatch script is also
> removed.
> 
> Signed-off-by: Sergio Paracuellos <sergio.paracuel...@gmail.com>
> ---
>  drivers/staging/ks7010/ks_wlan.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/ks7010/ks_wlan.h 
> b/drivers/staging/ks7010/ks_wlan.h
> index aeabbe3..ff6b65a 100644
> --- a/drivers/staging/ks7010/ks_wlan.h
> +++ b/drivers/staging/ks7010/ks_wlan.h
> @@ -87,7 +87,7 @@ enum {
>  #define SME_WEP_VAL2        BIT(6)
>  #define SME_WEP_VAL3        BIT(7)
>  #define SME_WEP_VAL4        BIT(8)
> -#define SME_WEP_VAL_MASK    (SME_WEP_VAL1 | SME_WEP_VAL2 | SME_WEP_VAL3 | 
> SME_WEP_VAL4)
> +#define SME_WEP_VAL_MASK    GENMASK(8, 5)

The original seems more readable to me.

regards,
dan carpenter

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to