On Thu, 2018-06-07 at 23:29 -0400, Janani Sankara Babu wrote:
> This patch is created to solve the warning shown by checkpatch script
> Prefer using '"%s...", __func__' to using ', this function's name,
> in a string
[]
> diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c 
> b/drivers/staging/rtl8192e/rtl819x_BAProc.c
[]
> @@ -127,7 +127,7 @@ static struct sk_buff *rtllib_ADDBA(struct rtllib_device 
> *ieee, u8 *Dst,
>       }
> 
>  #ifdef VERBOSE_DEBUG
> -     print_hex_dump_bytes("rtllib_ADDBA(): ", DUMP_PREFIX_NONE, skb->data,
> +     print_hex_dump_bytes("%s(): ", __func__, DUMP_PREFIX_NONE, skb->data,
>                            skb->len);

You didn't compile this with VERBOSE_DEBUG enabled.

You are adding arguments to a function that takes
a fixed number of arguments.

checkpatch is mindless.

Please don't mindlessly do what it says, just try
to improve the code readability where it's unclear
and especially try to find and fix logic defects.

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to