On Sat, 2018-08-18 at 20:28 +0530, Bhaskar Singh wrote: > On Sat, Aug 18, 2018 at 10:33:31PM +0800, zhong jiang wrote: > > On 2018/8/18 22:24, Bhaskar Singh wrote: > > > This patch might suppress some warrning. > > > > > > The function prototype of rtw_malloc2d is > > > > > > void *rtw_malloc2d(int h, int w, int size) > > > > > > This patch also resolves the checkpatch.pl warning > > > > > > WARNING: line over 80 characters
Please look deeper at the code than checkpatch. This function is used exactly once and could likely be removed and coded inline instead to improve readability. > > > Signed-off-by: Bhaskar Singh <bhaskar.ker...@gmail.com> > > > --- > > > drivers/staging/rtl8188eu/core/rtw_efuse.c | 3 ++- > > > 1 file changed, 2 insertions(+), 1 deletion(-) > > > > > > diff --git a/drivers/staging/rtl8188eu/core/rtw_efuse.c > > > b/drivers/staging/rtl8188eu/core/rtw_efuse.c > > > index 0fd306a808c4..735d654b2844 100644 > > > --- a/drivers/staging/rtl8188eu/core/rtw_efuse.c > > > +++ b/drivers/staging/rtl8188eu/core/rtw_efuse.c > > > @@ -91,7 +91,8 @@ efuse_phymap_to_logical(u8 *phymap, u16 _offset, u16 > > > _size_byte, u8 *pbuf) > > > if (!efuseTbl) > > > return; > > > > > > - eFuseWord = (u16 **)rtw_malloc2d(EFUSE_MAX_SECTION_88E, > > > EFUSE_MAX_WORD_UNIT, sizeof(u16)); > > > + eFuseWord = (u16 **)rtw_malloc2d(EFUSE_MAX_SECTION_88E, > > > + EFUSE_MAX_WORD_UNIT, (int)sizeof(u16)); > > > > > > > You should be align with left parenthesis. > > > > Thanks, > > zhong jiang > > > if (!eFuseWord) { > > > DBG_88E("%s: alloc eFuseWord fail!\n", __func__); > > > goto eFuseWord_failed; > > > > > > why post-commit doesn't give some warrning about that (because commits are > checked by > post-commit script)? > Do I need to resend the patch? > _______________________________________________ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel