On 2020-07-13 17:50 +0530, Suraj Upadhyay wrote:
> Simplify while loops into more readable and simple for loops.
> 
> Signed-off-by: Suraj Upadhyay <usura...@gmail.com>
> ---
[...]
> @@ -1824,7 +1821,7 @@ static struct sk_buff *ql_build_rx_skb(struct 
> ql_adapter *qdev,
>                       sbq_desc->p.skb = NULL;
>                       skb_reserve(skb, NET_IP_ALIGN);
>               }
> -             do {
> +             for (; length > 0; length -= size, i++) {
>                       lbq_desc = ql_get_curr_lchunk(qdev, rx_ring);
>                       size = min(length, qdev->lbq_buf_size);
>  
> @@ -1839,7 +1836,7 @@ static struct sk_buff *ql_build_rx_skb(struct 
> ql_adapter *qdev,
>                       skb->truesize += size;
>                       length -= size;
>                       i++;
> -             } while (length > 0);
> +             }

Looks like length and i modification should be removed from here. But in
this instance, maybe the original was better anyways.

Agreed with Dan. At least some of those loops can be converted to "count
up" loops for a more familiar appearance.

Attachment: signature.asc
Description: PGP signature

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to