On 04/28/18 07:41, Haojian Zhuang wrote: > Changelog: > v7: > * Fix memory leakage on DevicePath. > v6: > * Remove redundant definition -- "GRUB_FILE_NAME". > v5: > * Avoid to merge device path and grub's file path in driver. > Merge them directly in DSC file. > * Avoid duplicated code to create boot options. > * Use goto to handle error condition. > v4: > * Add BootCount parameter in the interface. > v3: > * Move in initilization of boot entry. > * Update the name of interface in platform boot manager protocol. > v2: > * Update with platform boot manager protocol. > > Haojian Zhuang (2): > Platform/HiKey960: register predefined boot options > Platform/HiKey: create 4 boot options > > Platform/Hisilicon/HiKey/HiKey.dec | 8 +- > Platform/Hisilicon/HiKey/HiKey.dsc | 7 + > Platform/Hisilicon/HiKey/HiKeyDxe/HiKeyDxe.c | 163 ++++++++++++++++++++ > Platform/Hisilicon/HiKey/HiKeyDxe/HiKeyDxe.inf | 11 ++ > .../{HiKey/HiKey.dec => HiKey960/HiKey960.dec} | 17 +-- > Platform/Hisilicon/HiKey960/HiKey960.dsc | 6 + > .../Hisilicon/HiKey960/HiKey960Dxe/HiKey960Dxe.c | 164 > +++++++++++++++++++++ > .../Hisilicon/HiKey960/HiKey960Dxe/HiKey960Dxe.inf | 11 ++ > 8 files changed, 375 insertions(+), 12 deletions(-) > copy Platform/Hisilicon/{HiKey/HiKey.dec => HiKey960/HiKey960.dec} (56%) > > Cc: Laszlo Ersek <ler...@redhat.com> > Cc: Leif Lindholm <leif.lindh...@linaro.org> > Cc: Ard Biesheuvel <ard.biesheu...@linaro.org> >
series Acked-by: Laszlo Ersek <ler...@redhat.com> Thanks Laszlo _______________________________________________ edk2-devel mailing list edk2-devel@lists.01.org https://lists.01.org/mailman/listinfo/edk2-devel