Chris Lesiak napisaĆ(a): > Michael, > > You might also consider eliminating the goto interpret_again loop in > emcTaskPlan() by changing it to a do loop. > This would cause a need to re-indent a large block, leading to a large > diff, but if the body of the loop were placed in a function it would be > a win in readability. > The variables readRetval and execRetval should probably also have their > scope reduced. > > If you don't want to make these changes yourself, I'll submit a patch > myself after the switch to git. > >
You are right Chris, I have added these changes to patch. Thanks for pointing this out. Michael ------------------------------------------------------------------------------ OpenSolaris 2009.06 is a cutting edge operating system for enterprises looking to deploy the next generation of Solaris that includes the latest innovations from Sun and the OpenSource community. Download a copy and enjoy capabilities such as Networking, Storage and Virtualization. Go to: http://p.sf.net/sfu/opensolaris-get _______________________________________________ Emc-developers mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/emc-developers
