When this gets pushed just tell me what and how it works and I'll update 
the docs.

JT

On 9/23/2016 1:50 PM, tero.kaarl...@eka-sorvaus.fi wrote:
> Hi,
>
>     It seems I was wrong. DISABLE_SPEED_OVERRIDE and DISABLE_FEED_HOLD do 
> work. Using halmeter for pin motion.spindle-speed-out confirmed correct 
> behaviour. Also Feed_hold_disable works but it was not what I was looking 
> for. I was hoping to disable halui.program.pause during G84 cycle. How should 
> I implement that?  Also G74 and G84 are now in same function "int 
> Interp::convert_cycle_g74_g84" because despite rotation directions behaviour 
> is same. Is this good way to do this or should I separate both to own 
> functions for clarity?
>
> --
> Tero Kaarlela
> Production Engineer
> Eka-Sorvaus OY
> Nivala
> Finland
>
> ----Alkuperäinen viesti----
> Lähettäjä : tero.kaarl...@eka-sorvaus.fi
> Pvm : 23/09/2016 - 09:53 (EEST)
> Vastaanottaja : emc-developers@lists.sourceforge.net
> Aihe : Re: [Emc-developers] Adding G84/G74 floating tapping cycles
>
> Hi,
>
>     As I mentioned before plan is to use Michaels code from here
>     http://git.mah.priv.at/gitweb/emc2-dev.git/shortlog/refs/heads/g84-dev
>     I just need to get these 4 year old patches to work with current
>     master. Patches from Canon: add optional wait_for_atspeed parameter
>     to START... to top. 1. problem was solved by adding this
>     introduction to top of file static const char* plane_name(CANON_PLANE p);
>     
>     2. Problem was that when only speed is
>     changed what should I pass to motion.wait_for_at_speed. But I solved
>     it by passing same state than it was before since it is not needed
>     to change this one if speed only changes this needs changing only
>     when spindle direction changes or when spindle stops.
>
>     But now I have a problem with Adding disable_feed_override() 
> disable_speed_override
>     and disable_feed_hold() during tapping(from r-level to r-level)
>     disable_feed_override works like it should but disable_speed_override()
>     and disable_feed_hold() seem to do nothing. These are needed to
>     avoid broken taps if user has set feeds/speeds to something else
>     than 100% before tapping starts(or during tapping). Okumas tend to
>     disable overrides during tapping cycles. Only way to stop tapping
>     during cycle is E-stop.
>
> Tero
>
> Thu, 22 Sep 2016 14:41:59 -0600 Sebastian Kuzminsky <s...@highlab.com>
> wrote:
>> On 09/22/2016 12:48 PM, tero.kaarl...@eka-sorvaus.fi wrote:
>>> Hi,
>>>
>>>    I need to add G84 canned cycle for tapping with floating holder.
>>> I found Michaels work here
>>> http://git.mah.priv.at/gitweb/emc2-dev.git/shortlog/refs/heads/g84-dev
>>> And was able to add interp/g84,g74: floating tap cycle  and canon:
>>> add optional wait_for_atspeed . Later is for overriding
>>> spindle_at_speed waiting after changing spindle rotation direction
>>> before pulling Z back from bottom of thread. But I have few
>>> questions:
>> Hi Tero, welcome!
>>
>>
>>> 1. In interp_cycles.cc there was plane_name(plane)  used and it is
>>> now obsolete? What to use instead? ie. ERS("G%c4 for plane %s not
>>> implemented",  op, plane_name(plane));
>> plane_name() is still in interp_cycles.cc, it is not obsoleted.
>>
>>
>>> 2. There has been changes in taskintf.cc emcSpindleSpeed function.
>>> It seems to call emcSpindleOn function nowadays instead of directly
>>> using emcmotCommand. And now this call:
>>>
>>> int emcSpindleSpeed(double speed, double css_factor, double offset)
>>> {
>>>
>>> if (emcmotStatus.spindle.speed == 0)
>>> return 0; //spindle stopped, not updating speed
>>>
>>> return emcSpindleOn(speed, css_factor, offset, 1); <==
>>> }
>>>
>>> Gives me error: Too few arguments passed to emcSpindleOn function.
>>> I added that 1 so emcSpindleSpeed always turns on
>>> wait_for_spindle_at_speed. But is there a better way?
>> What version of the code are you looking at that emcSpindleOn() takes
>> 4 arguments?  In 2.6, 2.7, and the master branch it takes 3
>> arguments.  Is the 4th argument something you're trying to add?
>>
>> If you added a 4th argument to emcSpindleOn() you'd have to update
>> every caller of that function to pass in something sensible there.
>>
>> But maybe we should take a step back first; how are you planning to
>> implement G84?  What's the desired behavior, and what's the code
>> changes you're planning to make to implement that behavior?
>>
>>
>>> 3. How can I run diff of my local source agains current master?
>> If you're working in a local clone of our git repo, you run "git diff
>> origin/master".
>>
>> If you have not already read our guide for contributors, it may
>> answer some of your workflow questions:
>> http://linuxcnc.org/docs/2.7/html/code/contributing-to-linuxcnc.html
>>
>>
>> -- 
>> Sebastian Kuzminsky
>


------------------------------------------------------------------------------
_______________________________________________
Emc-developers mailing list
Emc-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/emc-developers

Reply via email to