Hey,

> +EAPI int                     ecore_x_randr_present();
> EAPI int                     ecore_x_randr_events_select(Ecore_X_Window win, 
> int on);
> EAPI void                    
> ecore_x_randr_get_screen_info_prefetch(Ecore_X_Window window);
> EAPI void                    ecore_x_randr_get_screen_info_fetch(void);

> +EAPI int
> +ecore_x_randr_present()
> +{
> +#ifdef ECORE_XRANDR
> +   int randr_base = 0;
> +   int randr_err_base = 0;
> +
> +   if (XRRQueryExtension(_ecore_x_disp, &randr_base, &randr_err_base))
> +     return 1;
> +   else
> +     return 0;
> +#else
> +   return 0;
> +#endif
> +}

can you please use ecore_x_randr_query instead of _present ? It's the name 
we use for that kind of function with the X extensions. It's better to use 
uniform naming convention.

thank you

Vincent

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to