On 08/12/11 04:43, Daniel Juyung Seo wrote:
> Hello Tom,
> Thanks for you fix.
>
> I have one question here.
> I think this macro has no big benefit.
>
> +#define BASE(it) (&(it)->base)
>
> There is no much difference between "BASE(it)" and "it->base".
> But there are two macros for base.view and base.widget in elm_widget.h
>
> #define VIEW(X) X->base.view
> #define WIDGET(X) X->base.widget
>
> If BASE macro is necessary, the best place is elm_widget.h.
> Thank you.

Dear Daniel,

The reason I used BASE was because I didn't/couldn't assume the name of 
that structure field. doing it->base is bad, because base is never 
clearly stated anywhere there. Doing it in a macro/casting would have 
been more appropriate, that's why I chose the one option that can easily 
be turned to both.

I didn't do anything drastic, because I don't know those changes well 
enough. I'd expect to have a function/macro to retrieve the "disabled" 
status from an Elm_Object_Item.

Please think about it and decide what you think is needed to be done.

--
Tom.

------------------------------------------------------------------------------
Cloud Services Checklist: Pricing and Packaging Optimization
This white paper is intended to serve as a reference, checklist and point of 
discussion for anyone considering optimizing the pricing and packaging model 
of a cloud services business. Read Now!
http://www.accelacomm.com/jaw/sfnl/114/51491232/
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to