On Tue, Nov 23, 2010 at 2:12 AM, Asen Bozhilov <asen.bozhi...@gmail.com>wrote:

> David Herman:
>
> >> // "new" more readable sugar
> >> function()
> >> {
> >>  static x = 1; // hello c/c++
> >>
> >>  return ++x;
> >> }
>
> This would produce incompatibilities with ECMAScript 5 non-strict
> code.  The word `static` can be used as an Identifier in ES5
> non-strict mode.
>

Any ES5 non-strict code that uses "static" as an identifier is already
incompat with ES5/strict, so this is not an issue. The case against "static"
seems strong, but this does make it stronger.


> _______________________________________________
> es-discuss mailing list
> es-discuss@mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>



-- 
    Cheers,
    --MarkM
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to