Two names seems like a bad compromise. We should either do `next(...args)`
or `resume(...args)`. Not both.


On Tue, May 14, 2013 at 11:12 AM, Andreas Rossberg <rossb...@google.com>wrote:

> On 14 May 2013 17:07, Allen Wirfs-Brock <al...@wirfs-brock.com> wrote:
> >
> > What about providing a convenience "resume" method on generators to help
> clarify co-routine style usage?  Dave suggested that "resume" was
> pedagogically useful.
> >
> > I would define it equivalently two:
> >
> >    resume(...args) {return this.next(...args};
> >
> > (resume rather than next delegates to avoid the delegation for normal
> for-of iterations)
>
> Not sure about having two names for the same method, but if so, why
> not simply make Generator.prototype.resume ===
> Generator.prototype.next?
>
> /Andreas
> _______________________________________________
> es-discuss mailing list
> es-discuss@mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>



-- 
erik
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to