I realize that this is nit-picky, but the name `RequireObjectCoercible` feels 
wrong (and not intention-revealing) in the following context (which is not 
about objects at all):

1. Let O be ? RequireObjectCoercible(`this` value).
2. Let S be ? ToString(O).

Something like `RequireActualValue` or `ThrowIfUndefinedOrNull` seems like a 
better choice here.

-- 
Dr. Axel Rauschmayer
a...@rauschma.de
rauschma.de



_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to