I know the "what majority does" answer, yet I wonder if to avoid API fragmentation we should stick in the specification the fact that ECMAScript is a `camelCase` oriented programming language.
This will put an end to those coming from C, Python, Ruby, or PHP using `property_name` for their new API and developers will finally have a minimal guide on language naming convention. It is backward compatible, since IIRC there are no exception to this unwritten rule in older specs or APIs, and it will hopefully grant future consistency. It shouldn't be different from what WebIDL has already, if anything, since also WebIDL follows same convention. Thoughts? Best Regards
_______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

