make it shorter, simpler and more handy

deprecate this
```
EventTarget.addEventListener(...)
EventTarget.removeEventListener(...)
```

in pro of
```
EventTarget.on(...)
EventTarget.off(...)
```

make it easier, more intuitive and more readable
```
button.on(‘click’, e => ...)
form.on('submit', e => ...)
document.on('DOMContentLoaded', () => ...)
...
```

(and reduce code length)
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to