Hello, May I make a pitch for an expanded function syntax? This example will say it all (I hope).
What I have to write now: getFirstChildOfElementWithTagName(Papa, 'baby'); What I'd like to be able to write: getFirstChildOfElement(myPapa)withTagName('baby'); function getFirstChildOfElement(Papa)withTagName(babyTagName) { alert(Papa.tagName); // Show Papa's tag name alert(babyTagName); // Show baby's desired tag name } I don't think such an expanded capability would have any backward compatibility issues. It would make function calls more readable and easier to remember. Thanks, and ciao -- Mark Filipak _______________________________________________ Es4-discuss mailing list Es4-discuss@mozilla.org https://mail.mozilla.org/listinfo/es4-discuss