Hi Vlad,
Please pull from
git://git.openfabrics.org/~vu/ofed_1_3.git
This pull some fixes for srpt in ofed-1.3
GIT COMMIT COMMENTS
---------------------------------------
srpt: Fix compilation error in 2.6.24-rc2
Using sg_set_page() in 2.6.24 instead of accessing sg fields directly
Relying on scatterlist.h in backport header to support older kernels
Signed-off-by: Vu Pham <[EMAIL PROTECTED]>
srpt: Fix data corruption of using local mempool without lock
Change the local buffer allocator to use a spin-lock protected linked
list instead of an array of atomic_t used/free variables. The atomic_t
code was open to a multi-thread race between test and set. This has
been observed with the result that the same data buffer was used for
more than one SCSI operation, either writing the wrong data to the disk
or sending the wrong data to the initiator.
Signed-off-by: Robert Pearson <[EMAIL PROTECTED]>
Signed-off-by: David A. McMillen <[EMAIL PROTECTED]>
srpt: Add qp and port asynchronous events handling
Port error: set port lid, sm_lid to zero
Port active/lid change/pkey change/sm change: refresh port for lid/sm_lid
QP event on last wqe reached to clean up connection/session
Signed-off-by: Vu Pham <[EMAIL PROTECTED]>
srpt: Return the correct scsi status
Return correct scsi error status in srp response, set expected data
len, and
call scst_tgt_cmd_done for aborted command, srp response for aborted
command
will be send in srpt_task_mgmt callback
Signed-off-by: Vu Pham <[EMAIL PROTECTED]>
srpt: Fix bug in connection tear down to allow clean module unload
Fix bug in connection tear down to allow clean module unload or multiple
connect/disconnect/reconnect from initiators. Fix race condition between
rtu schedule work and ib_cm_notify. Thanks to Robert H.B Netzer
<[EMAIL PROTECTED]> for debugging and fixing them
Signed-off-by: Vu Pham <[EMAIL PROTECTED]>
srpt: Avoid calling ib_unregister_client twice when fail to register
with scst
Signed-off-by: Vu Pham <[EMAIL PROTECTED]>
srpt: Add and maintain active scst_cmd list for error handling cases.
Modify other
lists' name for better readability ie. completion list, wait command
list...
Signed-off-by: Vu Pham <[EMAIL PROTECTED]>
srpt: Code to have a clean round up to power of 2 for mem_pool element
Signed-off-by: David A. McMillen <[EMAIL PROTECTED]>
srpt: Using full initiator port ID as session name
Signed-off-by: Vu Pham <[EMAIL PROTECTED]>
thanks,
-vu
_______________________________________________
ewg mailing list
ewg@lists.openfabrics.org
http://lists.openfabrics.org/cgi-bin/mailman/listinfo/ewg