This is an automated email from the git hooks/post-receive script.

Git pushed a change to branch master
in repository ffmpeg.

    from 2e93d7c381 doc/protocols: State that the shared cache key ignores 
request options
     new 8579e070cb swscale/format: simplify ff_sws_op_list_generate() error 
handling
     new c35825a5f2 swscale/format: make ff_sws_op_list_generate() internals 
private
     new e63899bcb6 swscale/ops: always call ff_sws_op_list_update_comps() 
before printing
     new f026ab42b9 swscale/ops: bikeshed ops list print layout
     new 2cbff5cfce swscale/ops_optimizer: don't set .comps when inserting 
clears
     new a3d9acfaed swscale/ops: switch SwsComps from SoA to AoS
     new 50c0282615 swscale/ops: move structs (cosmetic)
     new 5f2a38d11c swscale/ops: add link back to owning SwsOpList
     new 40997528d5 swscale/ops: store SwsPixelType in SwsReadWriteOp
     new 153a0ae702 swscale/ops: add type[4] to SwsLinearOp
     new 6d5392e634 swscale/ops: add SwsPixelType to SwsClearOp
     new 3367cee3ba swscale/ops: keep track of pixel type on the output pad
     new 2171f9836c swscale/ops: add ff_sws_op_prev/next() helpers
     new cb2b7fde78 swscale/ops: add helper functions to determine op 
input/output types
     new 53369160a6 swscale/ops: nuke op->type across the board
     new 7c15cb8b34 swscale/ops: nuke SWS_COMP_GARBAGE
     new 791bf247f3 swscale/ops: stop nuking output pad metadata on unused 
output pads
     new dd8d79752c swscale/ops: simplify apply_filter_weights slightly
     new b6969106a9 swscale/ops: assume read ops forward untouched extra lanes
     new 25328c55da swscale/ops: split up ff_sws_op_list_update_comps()
     new 29486eacc1 swscale/ops: convert indented block to inverted continue 
(cosmetic)
     new 7e6151c0b3 swscale/ops: split op referencing to op_ref()
     new a112c7577d swscale/ops: rename op_uninit() to op_unref()
     new 5b9a4697e6 swscale/ops: remove dead declaration
     new 6b68670d77 swscale/ops: simplify update_output_pads() slightly 
(cosmetic)
     new 181ee7caf8 swscale/ops: comment bikeshedding
     new 2cc8f29b68 swscale/ops: rename ff_sws_op_list_update_comps()

The 27 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 libswscale/format.c         | 202 +++++------
 libswscale/format.h         |  40 ---
 libswscale/graph.c          |   1 +
 libswscale/ops.c            | 851 +++++++++++++++++++++++---------------------
 libswscale/ops.h            |  97 +++--
 libswscale/ops_dispatch.c   |  17 +-
 libswscale/ops_memcpy.c     |   2 +-
 libswscale/ops_optimizer.c  | 105 +++---
 libswscale/uops.c           |  84 ++---
 libswscale/vulkan/ops.c     |  52 +--
 tests/ref/fate/sws-ops-list |   2 +-
 11 files changed, 736 insertions(+), 717 deletions(-)

-- 
To stop receiving notification emails like this one, please contact
[email protected].
_______________________________________________
ffmpeg-cvslog mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to